Help Center

Need help using Fulcrum? Get answers to your questions here.

What are the minimal OS versions for iOS and Android?

Fulcrum can be run on devices running Android 4.0.3 or higher and minimal iOS versions 8.4 or higher. The app can be downloaded for an Android device at the Play Store For iOS users, Fulcrum can be downloaded at the iTunes Store

Contact Us to Get Started

Thanks for contacting us!

Thank you so much for taking the time to send us your thoughts. We're always trying to improve Fulcrum and customer feedback helps tremendously.

Still have questions? Browse our support forum and drop us a line.

Go to support